출처: [백준] 11724번 연결 요소의 개수
시간 제한 |
메모리 제한 |
제출 |
정답 |
맞은 사람 |
정답 비율 |
3 초 |
512 MB |
42149 |
20184 |
13181 |
44.965% |
문제
방향 없는 그래프가 주어졌을 때, 연결 요소 (Connected Component)의 개수를 구하는 프로그램을 작성하시오.
입력
첫째 줄에 정점의 개수 N과 간선의 개수 M이 주어진다. (1 ≤ N ≤ 1,000, 0 ≤ M ≤ N×(N-1)/2) 둘째 줄부터 M개의 줄에 간선의 양 끝점 u와 v가 주어진다. (1 ≤ u, v ≤ N, u ≠ v) 같은 간선은 한 번만 주어진다.
출력
첫째 줄에 연결 요소의 개수를 출력한다.
예제 입력 1
예제 출력 1
예제 입력 2
1 2 3 4 5 6 7 8 9
| 6 8 1 2 2 5 5 1 3 4 4 6 5 4 2 4 2 3
|
예제 출력 2
힌트
출처
알고리즘 분류
풀이
소스코드_DFS(List1)
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
| import sys
sys.setrecursionlimit(10 ** 6) input = sys.stdin.readline
def dfs(graph, v, visited): visited[v] = True for i in graph[v]: if not visited[i]: dfs(graph, i, visited)
N, M = map(int, input().split()) graph = [[] for _ in range(N + 1)] visited = [False] * (N + 1) component = 0
for _ in range(M): src, dest = map(int, input().split()) graph[src].append(dest) graph[dest].append(src)
for i in range(1, N + 1): if not visited[i]: dfs(graph, i, visited) component += 1
print(component)
|
소스코드_DFS(List2)
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
| import sys
sys.setrecursionlimit(10 ** 6) input = sys.stdin.readline
def dfs(graph, v, visited): visited[v] = True for i in range(1, N + 1): if not visited[i] and graph[v][i] == 1: dfs(graph, i, visited)
N, M = map(int, input().split()) graph = [[0] * (N + 1) for _ in range(N + 1)] for _ in range(M): x, y = map(int, input().split()) graph[x][y] = 1 graph[y][x] = 1
visited = [False] * (N + 1) component = 0
for i in range(1, N + 1): if not visited[i]: dfs(graph, i, visited) component += 1 print(component)
|
소스코드_DFS(Dict)
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
| import sys
sys.setrecursionlimit(10 ** 6) input = sys.stdin.readline
def dfs(graph, v, visited): visited[v] = True for i in graph[v]: if not visited[i]: dfs(graph, i, visited)
N, M = map(int, input().split()) graph = {} for i in range(N + 1): graph[i] = set()
for _ in range(M): u, v = map(int, input().split()) graph[u].add(v) graph[v].add(u)
visited = [False] * (N + 1) component = 0
for i in range(1, N + 1): if not visited[i]: dfs(graph, i, visited) component += 1
print(component)
|